获得徽章 0
沉下心努力做出一个点,而不是被杂七杂八的面给湮没
评论
好汉不提当年勇,是因为现在已经不够勇,过去的成绩和风光再讲出来只会被人当成吹牛,招人烦,要么扛住挑战,要么闭嘴
评论
pnpm在electron build使用时,如果不使用webpack编译成AMD形式,直接将依赖build到asar的node_modules下时,由于pnpm的模块管理组织形式,其孙依赖模块将不会被打包进去,这时候还得使用npm进行build,不过开发时处于dev 模式下还是能找到这些依赖
评论
身体好才是一切的根本.....[流泪]
7
windows下npm install sharp,ERR! sharp Prebuilt libvips 8.10.5 binaries are not yet available for win32-x64的解决方案:到github.com 找到对应版本的libvips-x.x.x-win32-x64.tar.br压缩包,放到C:\Users\xxxxx\AppData\Roaming\npm-cache\_libvips然后再 npm i sharp
展开
评论
node.js中所有的带callback的函数最好由Promise封装后变成thenable对外输出resolve的结果
1
之前都是使用公司内部的持续集成,找公共的CI服务时还打算使用travis.ci,却要提供信用卡验证且credits是有限的,后来发现github actions就十分好用.
2
open.vscode.dev可以使用vscode打开访问github文件目录,但不会下载到本地,需要手动下载
评论
npm init vue@next 最快vue+vite的脚手架没有之一
评论
找工作最最重要的是什么? 是时机,其他的都往后排
4
在electron中引入sharp库时会安装依赖库canvas,不想使用node-gyp编译时canvas会优先使用node-pre-gyp 安装二进制包安装,在设置好canvas_binary_host_mirror后仍然获取不到二进制包,检查源码发现node-pre-gyp/lib/util/versioning/get_runtime_abi中在electron中获取node_abi时为electron-vX.XX形式,但二进制包仅提供node-vX.XX形式最后在get_runtime_abi中强制指定runtime=node完事,有知道更好解决方法的请评论。 ------- node-pre-gyp 解析参考zhuanlan.zhihu.com
展开
1
灵魂画手画了一些草稿,就作为原型交互交给开发来做,要想从一堆草稿中找到头绪,真是浪费生命
评论
vite vue3 vuex4 vue-router4 typescript, 4vt组合用起来还是不错
评论
下一页
个人成就
文章被点赞4
文章被阅读32,166
掘力值327
收藏集
4
关注标签
3
加入于