maven与idea版本适配问题

735 阅读1分钟

1. 版本对应关系——3.6.3

注意:针对一些老项目 还是尽量采用 3.6.3版本,针对idea各个版本的兼容性就很兼容 0.IDEA 2022 兼容maven 3.8.1及之前的所用版本 1.IDEA 2021 兼容maven 3.8.1及之前的所用版本 2.IDEA 2020 兼容Maven 3.6.3及之前所有版本 3.IDEA 2018 兼容Maven3.6.1及之前所有版本

2. idea因为版本问题产生的错误Process terminated

  1. 先查看日志分析原因

    SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder". SLF4J: Defaulting to no-operation (NOP) logger implementation SLF4J: See www.slf4j.org/codes.html#… for further details.

  1. 分析原因

    • maven版本不适合该版本idea
  2. 解决

    • 更换版本为3.6.3