在脚手架里面选择了ESLint后npm装包时会出现的依赖冲突

·  阅读 4733

今天装包的时候一直报错误,烦都烦死了

image.png

image.png

有道翻译了一下大致上是上面上游依赖冲突.

怎么解决呢?百度了半天,果然百度才是yyds

因为npm版本省级了,(v8.3.1)

npmV7之前的版本遇到依赖冲突会忽视依赖冲突,继续进行安装

npmV7版本开始不会自动进行忽略,需要用户手动输入命令

有两个命令可以解决此问题

  • 一是 --force 无视冲突,强制获取远端npm库资源 (覆盖之前)

  • 二是 --legacy-peer-deps 忽视依赖冲突,继续安装(不覆盖之前)

正确的语句:npm install vue-router --force 或者 npm install vue-router --legacy-peer-deps

推荐使用--legacy-peer-deps

把npm版本回退一下也可以

image.png

image.png

//查看当前npm版本
npm -v 
复制代码

node的长期稳定版是16.15.0版本.我们就使用对应版本的npm包

//切换包的版本
npm install npm@8.5.5 -g --force
复制代码

最后再查一下版本看看npm的版本切换过来没有

**npm -v //查看当前npm版本**
复制代码

去下包试试看吧,我切换版本后就没有显示依赖冲突,可以正常下包了

分类:
前端
标签:
分类:
前端
标签:
收藏成功!
已添加到「」, 点击更改