阅读 3623
Unity使用中的错误 ✨ |打包出错

Unity使用中的错误 ✨ |打包出错

二、打包出错

问题:打包安卓包时老是出现SDK找不到或者版本低(明明JDK、SDK都配置好的前体下。我的unity19版本出现过好多次,一样的JDDK、SDK低版本Unity可以打包,19就不可以)

出现原因及解决:

①可能是最低安卓版本选的太高了,尝试下选中低版本,比如Android4.1等等

在这里插入图片描述

②如果使用的是unity2019或者以上,就通过UnityHub重新安装一个Unity,然后选择将JDK、SDK一块下载了。这样是最好的解决办法,省时省劲。

③报错提示这个:”ArgumentException: Illegal characters in path.+一大串英文“
这个错误挺常见的,就是打包路径错误,可能打包的路径出现了中文或者非法字符串导致的。但是我之前打包的时候路径确定没错也出现了(Windows可以打包,换成打包安卓就不行),找了大半天不知道什么原因导致,重装了unity也不行。请公司大佬出手半天也没解决,最后重新配置了JDK与SDK终于可以打包了(生活不易啊>_<) 最后查明原因应该是jdk跟sdk环境配置出现了问题。 配置JDK与SDK的也可以参考下这个

文章分类
前端
文章标签