vue使用webpack-obfuscator

·  阅读 845

vue2.6 + vue-cli3 构建代码混淆 webpack-obfuscator

git地址:github.com/javascript-…

需要一起安装 javascript-obfuscator

npm install --save-dev javascript-obfuscator webpack-obfuscator

注意版本2.6.0以上需要webpack5

vue.config.js文件中configureWebpack配置

configureWebpack 是webpack在vue-clie的配置信息类似webpack.config.js

code.png


版本兼容

image.png

webpack4最高使用版本webpack-obfuscator@2.6.0

找不到模块

image.png

Javascript-obfuscator是对等依赖,所以必须手动安装 www.npmjs.com/package/jav…

package.json文件


"terser-webpack-plugin": "^4.2.3" // 压缩代码

"webpack-obfuscator": "^2.6.0" // 混淆

"javascript-obfuscator": "^2.19.0"

复制代码

参考文章:www.cnblogs.com/dragonir/p/…

分类:
前端
标签: