elementPlus 自定义主题

·  阅读 1711
elementPlus 自定义主题

我还是那句话,没有环境标明的就是耍流氓 win7系统 nvm node:10.24.1 yarn 这个真的搞人心态。坑多 本项目没有用到sass,所以用的cli构建。

开始的时候我的node版本是12.19.1。

安装

yarn add element-theme -D 然后!yarn add element-theme-chalk -D 安装顺序一定要按顺序。(反正开始我没按顺序,遇到很多问题) 然后选择node_modules下的.bin目录,右键打开cmd

image.png 然后执行命令 et -i

:primordials is not defined, google:这个错误的问题是 Node 的版本过高,把 Node 降到 11.15.0 以下就可以,也有人说最好用 10版本的。 然后本人用nvm 将版本切换到v10.24.1.再次执行。

nvm 假如没安装,自己搜一下,记得windows是要安装nvmw 的,别自己配置了,就选最简单的那个选项,环境变量也不用自己添加。不要用nvm for windows 不太好用。不太推荐。

image.png

成功后,居然没有element-variables.scss文件,不是说好在当前文件夹下面吗,眼睛都找瞎了。- 💢

ps:掘金今天居然可以使用Emoji了,啊哈哈哈,不过为啥是图片。

然后我关掉!!!了vscode ,重新打开。他出现了。心里几千万只cnm在心中奔腾,嘶吼 - 🤬

image.png ps:这其中其实还有其它坑,说我没有安装pythen 了,说我没有安装node-sass了。我可去了***。就照我上面的来。娘希匹。

老泪纵横。涕流满面.愿天下开发长命百岁,永不脱发!

分类:
前端
标签:
收藏成功!
已添加到「」, 点击更改