阅读 2166

如何找到webpack对应的loader版本

困扰了好一会,记录一下学习过程。 如果有不正确的地方麻烦耐心指出。(菜鸡的自我修养)

loader是什么

webpack是前端常见的模块打包工具,但是webpack只能用来处理js代码及其间的依赖。

而前端除了js外还有很多文件,包括css、图片等等,这些文件的打包需要webpack的扩展来实现,这个扩展就是loader。

如何找到对应的loader

搜索webpack,进入官网 -》文档 -》loaders

比如我想加载css的loader,进入样式-》css-loader中查看其安装和配置

loader版本问题

我们按照官网提供的安装方法进行安装,难免会碰到与当前webpack版本不匹配的问题,更改webpack版本不太现实,所以需要安装低版本的loader来实现。

那么怎么知道哪个版本的loader适合自己的webpack版本呢

  1. 首先查看自己的webpack版本号。

  1. 明确自己要找什么loader,这里我以url-loader为例。
  2. 进入github查找url-loader。

  1. 通过tag选择不同的版本,以v1.1.2为例

5. 进入package.json文件进行查看

可以知道该版本支持以3,4开头的webpack,满足自己主机的webpack版本号。适配成功

  1. 最后使用npm install --save-dev url-loader@1.1.2进行安装(--save-dev表示只在开发环境中使用)
文章分类
前端
文章标签