vue3.0安装element-ui产生的错误

·  阅读 2910

事件起因:不止音乐项目 vue3.0在制作的过程中,我想加入element-ui中的icon,便去下载,后来在下载过程中报了错[如下图]

安装element-ui时发生错误

vue3.0在安装element-ui完整引入时发生的错误

解决方法

  1. 安装一下node-gyp
npm install -g node-gyp    
复制代码
  1. 更改一下sass地址为taobao
npm config set sass_binary_site=https://npm.taobao.org/mirrors/node-sass  
复制代码

npm run serve时又报错了

因为完整引入了element-ui,导致在npm run serve的时候,出现了错误,把我的app.vue给初始化成最初的样子了

 ERROR  Failed to compile with 2 errors                                                                            22:30:34
These relative modules were not found:
复制代码
  • ./assets/logo.png in ./node_modules/cache-loader/dist/cjs.js?{"cacheDirectory":"node_modules/.cache/vue-loader","cacheIdentifier":"8db79c6a-vue-loader-template"}!./node_modules/vue-loader/lib/loaders/templateLoader.js??vue-loader-options!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=template&id=7ba5bd90&
  • ./components/HelloWorld.vue in ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/App.vue?vue&type=script&lang=js&

解决方法

这两个错误是因为我删除了asssets目录下的logo.png文件,所以它找不到了,于是我就把App.vue中的使用logo.png的代码删除了,第二个错误是由于找不到helloWorld文件,也是因为我删除了这个文件,于是在App.vue中的使用helloWorld的代码删除了

重新下载element-ui再次运行开始报错

后来项目可以运行了,我就重新安装了一遍element-ui,然后就不报错了,但是在我项目运行时出现了新的问题

 ERROR  Failed to compile with 2 errors                                                            22:54:34

These dependencies were not found:

  • element-ui in ./src/plugins/element.js
  • element-ui/lib/theme-chalk/index.css in ./src/plugins/element.js
复制代码

To install them, you can run: npm install --save element-ui element-ui/lib/theme-chalk/index.css

解决方法 将node_modules包删除,重新下载

npm i
复制代码

然后就OK啦

本文使用 mdnice 排版

分类:
阅读
标签:
分类:
阅读
标签:
收藏成功!
已添加到「」, 点击更改