阅读 2356

解决 nvm is not compatible with the npm config "prefix"

Mac系统每次打开终端都会提示下面这段话

nvm is not compatible with the npm config "prefix" option: currently set to "/usr/local" 
Run `npm config delete prefix` or `nvm use --delete-prefix v8.11.0 --silent` to unset it.
复制代码

终端运行 nvm use --delete-prefix v8.11.0 --silent 可以解决,但是重新打开终端之后还是会有问题。

正确做法是删除并重新设置 nvm prefix

  1. 运行 nvm use --delete-prefix v8.11.0 --silent 确保npm命令可以使用;
  2. 运行 npm config delete prefix 删除 nvm prefix;
  3. 运行 npm config set prefix $NVM_DIR/versions/node/v8.11.0 设置 nvm prefix 为v8.11.0。

注意:更改版本号,用错误消息中的提示的版本号。

参考:github.com/nvm-sh/nvm/…