iOS 解决升级Xcode后插件不能使用的问题

·  阅读 681

从Xcode 5开始,苹果要求加入UUID证书从而保证插件的稳定性。因此Xcode版本更新之后需要在插件的Info.plist文件中添加当前Xcode的UUID。

具体步骤如下:

######1、获取Xcode的UUID

  在终端执行

defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID
复制代码

Paste_Image.png

或者在/Applications目录中找到Xcode.app,右键”显示包内容”,进入Contents文件夹,双击Info.plist打开,找到DVTPlugInCompatibilityUUID,拷贝后面的字符串。

######2、添加Xcode的UUID到插件的info.plist中 以VVDocumenter为例

  如果已经安装了插件     1、打开xcode插件所在的目录:~/Library/Application Support/Developer/Shared/Xcode/Plug-ins;  

  2、选择已经安装的插件例如VVDocumenter-Xcode,右键”显示包内容”;

  3、找到info.plist 文件,找到DVTPlugInCompatibilityUUIDs的项目,添加一个Item,Value的值为之前Xcode的UUID,保存。

Paste_Image.png

插件还未安装或重新安装   1、从GitHub克隆仓库到本地,在Xcode中打开项目,选择项目名称,在TAGETS下选中VVDocumenter-Xcode;

  2、选择Info,找到DVTPlugInCompatibilityUUIDs的项目,添加一个Item,Value的值为之前Xcode的UUID;

  3、Build项目,VVDocumenter-Xcode会自动安装。

######3、重启Xcode 重启Xcode时会提示“Load bundle”、 “Skip Bundle”,这里必须选择“Load bundle”,不然插件无法使用。

收藏成功!
已添加到「」, 点击更改