获得徽章 0
前端工程师
前端工程师
前端工程师
关注了
ndz
VIP.5 如鱼得水
前端工程师
关注了
掘金安东尼
VIP.5 如鱼得水
前端工程师
赞了这篇沸点
@冴羽 @Jsonz1993
今天不分享正则,说一个 node-sass 安装的坑
周五口嗨从朋友那边接了一个项目过来帮忙做需求
拿到项目开始使用 npm 安装以来结果报错
图一是所有的依赖
于是开始使用不同方法去解决
以下是我使用过的方法以及结论:
1.使用yarn 安装:报错
2.使用 cnpm 安装:报错
3.直接替换朋友的node_modules 报错系统不兼容,他用的 window,我的是苹果
4.使用淘宝源安装特定版本 报错:this.getOption is not defined
5.使用 dart-sass 替换 node-sass :报错,elementui 内的 sass 无法兼容
6.群里大家讨论甚至说要安装 python
7.之后在 node-sass 网站上找到图二
于是回退node 版本到 packagejson 中对应的版本
从 node16 回退到 node10 使用 npm 成功安装
经验教训:
1.不要随便口嗨帮人接需求
2.有问题第一时间看官方文档的说明,看别人的解决方案可能越走越远
展开
潘小安于2022-01-22 14:09发布的图片
潘小安于2022-01-22 14:09发布的图片
12
前端工程师
关注了
若川
VIP.5 如鱼得水
前端工程师
下一页
个人成就
文章被点赞 24
文章被阅读 3,498
掘力值 138
收藏集
5
关注标签
2
加入于