【PTA】1013 Battle Over Cities (图的dfs+统计连通分支数目)

116 阅读2分钟

本题考点:

  • 统计图的强连通分支数目

题目:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city​1 -city​2 and city1-city3.Then if city​1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2-city3
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0

本题需要的大意是去除掉图中某点之后,计算出剩余点的连通分支数目。

所以采用邻接矩阵(小于1000个点基本都没问题)保存图,然后使用 DFS 来遍历图,计算出所有的连通分支数目。

关于图的 dfs 和 bfs ,之前也做过类似的题目:PTA 7-33 地下迷宫探索 (图的DFS)

下面给出实现代码:

/* 
    统计连通分支总数
    邻接矩阵 + dfs
 */
#include <iostream>
#include <vector>
#define LOCAL
using namespace std;

const int maxn = 1010;

int N, M, K;    // 城市总数,道路总数,需要检查的城市总数
int G[maxn][maxn];
bool vis[maxn]; // 看是否被访问过
int checkedCity;

void dfs(int city)
{
    for (int i = 1; i <= N; i++)
    {
        if(G[city][i] == 1 && vis[i] == false && i != checkedCity)
        {
            vis[i] = true;
            dfs(i);
        }
    }
}


int dfsTravel(int city)
{
    fill(vis, vis + maxn, false);   // 初始化为未访问
    int ans = 0;
    for (int i = 1; i <= N; i++)
    {
        if(vis[i] == false && i != checkedCity)
        {
            vis[i] = true;
            dfs(i);
            ans++;
        }
    }
    return ans - 1;
}

int main()
{ 
    // freopen("data.txt", "r", stdin);
    scanf("%d%d%d", &N, &M, &K);
    int u, v;
    for (int i = 0; i < M; i++)
    {   // 读取道路总数, 保存道路之间关系
        scanf("%d%d", &u, &v);
        G[u][v] = G[v][u] = 1;
    }
    int city;
    for (int i = 0; i < K; i++)
    {
        scanf("%d", &checkedCity);
        printf("%d\n", dfsTravel(city));
    }

    return 0;
}