阅读 48

Martian 3.3.3发布,最低支持JDK11

Martian,一个JavaWeb开发框架,自2019年开始写下第一行代码,至今已有2年1个月,在各种 小框架的 围攻竞争下,艰难的生存着。 因为定位是一个 极简的框架,这跟很多框架产生了冲突,尤其是刚刚问世的时候,经常收到 一些吐槽,例如:没有新意。

但这并不影响我对这件事的热爱,我一直都在不断地做着维护,从一开始的一个微型项目,渐渐的发展成今天这样,期间集成过netty,tomcat,httpServer,但最终都因为 跟我一直坚持的 最小化原则 相违背 而放弃了。 最终选择了基于NIO自己实现http服务。

后来,因为NIO是 同步的,为了使其不被业务阻塞,故而加入了线程池,但是效果不是很理想。经过了再三的考虑,最终选择了AIO。也就是今天发布的这个版本。

本次的更新点如下

  1. 改用AIO,全面实现异步非阻塞
  2. 最低支持JDK11

这次更新有哪些影响

升级为AIO,只是内部变更,增加了一定的吞吐量,从使用者的角度来看,并没什么改变,所以不会产生什么负面影响

最低支持JDK11,这是一个很艰难的决定,因为可能会丢失一批潜在用户,甚至是正在使用的用户,但是我觉得,作为一名开发者 需要对新东西保持一定的敏感度,JDK8早晚会不堪重负,被淘汰是必然的趋势,所以我们作为业内人士 需要起到一定的带头作用(虽然我的影响力几乎为0,O(∩_∩)O哈哈~)。

那如果就是想在JDK8上运行怎么办? 可以下载源码,在本地自行编译,不使用中央库的jar包即可。 但是这么做也会存在另一个问题,就是随着版本的升级,源码里面肯定会用到JDK11的特性,到那个时候,将彻底不再支持JDK11以下的环境。 所以这招 在以后发行的版本的源码里 不一定行得通。

目前完美支持JDK8的版本是3.2.18,是NIO版本。

官网:mars-framework.com

文章分类
后端
文章标签