在 Ubuntu 上安装 Docker Engine

·  阅读 1455

要开始在 Ubuntu 上使用 Docker Engine,请确保满足先决条件,然后安装 Docker。

先决条件

操作系统要求

要安装 Docker Engine,你需要64位版本的 Ubuntu 版本:

Docker Engine 支持 x86 _ 64(或 amd64 )、 armhf 和 arm64体系结构。

卸载旧版本

旧版本的 Docker 被称为 Docker、 Docker.io 或 Docker-engine,如果已经安装了,请卸载它们:

$ sudo apt-get remove docker docker-engine docker.io containerd runc

如果 apt-get 报告没有安装这些软件包,就完成了。

保留 /var/lib/Docker/ 的内容,包括图像、容器、卷和网络。

支持存储驱动程序

Docker Engine 支持 overlay2,aufs 和 btrfs 存储驱动程序

Docker Engine 默认使用 overlay2存储驱动程序。如果您需要使用 aufs 代替,您需要手动配置它。请参阅使用 AUFS 存储驱动程序

使用存储库进行安装

首次在新主机上安装 Docker Engine 之前,需要设置 Docker 存储库。之后,您可以从存储库中安装和更新 Docker。

设置存储库

1.更新 apt 包索引和安装包,允许 apt 在 HTTPS 上使用存储库:

$ sudo apt-get update

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    gnupg-agent \
    software-properties-common

添加 Docker 的官方 GPG 密钥:

$ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

通过搜索指纹的最后8个字符,验证您现在有指纹 9DC8 5822 9FC7 DD38 854A E2D8 8D81 803C 0EBF CD88 的密钥。

$ sudo apt-key fingerprint 0EBFCD88

pub   rsa4096 2017-02-22 [SCEA]
      9DC8 5822 9FC7 DD38 854A  E2D8 8D81 803C 0EBF CD88
uid           [ unknown] Docker Release (CE deb) <docker@docker.com>
sub   rsa4096 2017-02-22 [S]

使用以下命令设置稳定存储库。

$ sudo add-apt-repository \
   "deb [arch=arm64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \
   stable"

安装 DOCKER 引擎

更新 apt package index,安装最新版本的 Docker Engine 和 containerd,或者进入下一步安装一个特定的版本:

 $ sudo apt-get update
 $ sudo apt-get install docker-ce docker-ce-cli containerd.io

要安装一个特定版本的 Docker Engine,在 repo 中列出可用的版本,然后选择并安装:

列出你的仓库中可以使用的版本:

$ apt-cache madison docker-ce

  docker-ce | 5:18.09.1~3-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu  xenial/stable amd64 Packages
  docker-ce | 5:18.09.0~3-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu  xenial/stable amd64 Packages
  docker-ce | 18.06.1~ce~3-0~ubuntu       | https://download.docker.com/linux/ubuntu  xenial/stable amd64 Packages
  docker-ce | 18.06.0~ce~3-0~ubuntu       | https://download.docker.com/linux/ubuntu  xenial/stable amd64 Packages
  ...

使用第二列的版本字符串安装一个特定的版本,例如5:18.09.1 ~ 3-0 ~ ubuntu-xenial。

$ sudo apt-get install docker-ce=<VERSION_STRING> docker-ce-cli=<VERSION_STRING> containerd.io

通过运行 hello-world 映像来验证 Docker Engine 安装是否正确。

$ sudo docker run hello-world

此命令下载测试映像并在容器中运行它。当容器运行时,它打印一条信息消息并退出。

卸载 Docker 引擎

卸载 Docker Engine、 CLI 和 Containerd 软件包:

$ sudo apt-get purge docker-ce docker-ce-cli containerd.io

上个命令不会自动删除主机上的映像、容器、卷或自定义配置文件。需要手动删除所有图像、容器和卷:

$ sudo rm -rf /var/lib/docker

您必须手动删除任何已编辑的配置文件。

分类:
开发工具
标签:
分类:
开发工具
标签:
收藏成功!
已添加到「」, 点击更改