阅读 1743

关于vue+webpack开发时让人无语的坑

在vue+webpack时会使用到各种依赖包等等,但是对于非前端工程师来说,可能会由于一些版本问题影响项目进度。所以说几个自己遇到的问题。

安装webpack时

由于webpack是一种自动化构建工具,强烈依赖node进行打包编译,所以,所以node与npm的版本是毕竟容易影响开发的,比如安装webpack时,由于node版本过低,一切依赖就会无法完全安装(如:webassemblyjs)。建议node安装到8.0.0以上版本,已经比较稳定了。

安装各种包时

由于大部分人使用npm进行包管理,但是服务器在国外,所以在下载的过程中会出各种问题,强烈建议使用cnpm。如执行 npm run dev时,报错为Module build failed: Error:sass-loaderrequiresnode-sass>=4. Please install a compatible version看原因还以为是版本问题,但是使用npm view node-sass version,显示的 4.9.0。于是执行 npm remove node-sass后 再执行cnpm install node-sass重新安装就可以了。

linux与Windows迁移开发时

由于两种平台的开发环境问题,虽然有时你在webpack设置了跨平台,但是还是可能出现问题,尤其是从linux下到Windows更容易出现这种问题,这时执行npm rebuild node-sass,重新安装环境依赖,再执行npm run build就可以了

文章分类
前端