2016.7.14最新cocoapods最新安装教程

·  阅读 102

cocoapods 依赖于ruby , 安装ruby的方法有很多,我知道的最简单的就是 brew install ruby

使用上面指令的前提是:你安装了homebrew ;homebrew的安装方法一直在改变 (但是安装方法更新在http://brew.sh)

今天是2016,7,12 安装方法是:/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"


一:安装brew:

1.开启 terminal

2.安装homebrew

$ /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"


二:安装ruby


1.开启 terminal

2.安装ruby

$ brew install ruby


三:安装cocoapods


1.开启 terminal

2.移除现有 Ruby 默认源

$ gem sources --remove https://rubygems.org/

3.使用新的源(此处为本文精华)

可解决:Error fetching https://ruby.taobao.org/:

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://ruby.taobao.org/specs.4.8.gz)

这个问题

这里特别说明: 淘宝不再更新和维护ruby源 所以导致原来的教程失效

// $ gem sources -a https://ruby.taobao.org/

//国内的ruby源

上面的是原来的,现在改为: https://gems.ruby-china.org/

4.验证新源是否替换成功

$ gem sources -l

5.安装 CocoaPods

$ sudo gem install cocoapods

$ pod setup

第一遍就这样吧!我还得写作业!就不截图了!!!!