RubyMine 停止对 Rails 3 的支持

Rails 3 已经停止更新多年,大多数开发者都选择更新至 Rails 较新版本,因此 RubyMine 2022.1 决定不再支持 Rails 3。

官方表示,先前更新公告中并未明确清晰的指出这个改动,影响了一些仍然使用 Rails 3 的用户,官方对此表示歉意,同时表示 v2021.1.1 就作为最后一个支持 Rails 3 的版本。也就是说,RubyMine 2022.2 开始,将不再支持 Rails 3,而且从 RubyMine 2022.2 开始,官方将不再修复与 Rails 3 相关的任何新问题。

此外,官方还决定弃用一下功能:

  • Rails View 作为 RubyMine 中显示项目结构的方式,目前不受用户欢迎,因此后续将默认禁用。如果用户如果还想使用该功能,可以根据文档使用,后续官方准备将其设计为单独的 RubyMine 插件。

  • `RCov gem: v2022.2 将默认禁用此功能,如果 IDE 检测到配置需要,建议重新启用

  • 对预加载服务器 - ZeusSporkNailgun 以及 JRubyCucumber 运行配置类型的支持将在 v2022.2 中弃用

RubyMine v2022.2 将在 2022 年第三季度的发布。

评论